Quinn-Curtis Forums
Quinn-Curtis Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Tools for Microsoft .Net & .Net Compact Framework
 QCChart2D and QCChart2D CF (VB and C#)
 Linear Axis Labels not showing up correctly

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
   

T O P I C    R E V I E W
soundar Posted - 09 Nov 2015 : 07:21:49
I have Linear axis data like this -
1.081
2.094
3.056
...
39.084

Linear axis values of the points are approx 1 apart (it IS linear axis, not time axis).
But instead of the x axis labels displaying values 0,1,2, etc, the labels show values of 0, 1000, 2000, 4000 !

I even checked if the values going in are correct by doing dataset.GetXDataValue() and it does report the values I had fed.

I have emailed an example by separate email. Note that x axis should go from 0 to 1 instead it goes from 0 to 10.

Any ideas why this could happen?



2   L A T E S T    R E P L I E S    (Newest First)
quinncurtis Posted - 10 Nov 2015 : 15:53:33
Your description is now completely different than what you posted on the forum.

You said that when the data was 0 to 40, "the labels show values of 0, 1000, 2000, 4000 "!

Then you modified that to say "Note that x axis should go from 0 to 1 instead it goes from 0 to 10."

Now you say data values of 0.1 to 9.1 result in x-axis scaling of 0 to 10.

This is what is expected. The auto-axis routines round the axis minimum to the smallest even value, and maximum up to the nearest even value. So 0.1 is rounded down to 0 and the 9.1 is rounded up to 10. The x-axis labels are then displayed using the numbers adjusted to that scale. This produces the neatest possible graph.

Please take the time to describe what your problem is in a consistent manner.

Also, please specify exactly which version of Visual Studio (VB) you created your example program using.
quinncurtis Posted - 09 Nov 2015 : 09:17:35
Our only guess is that the axis is being scaled against data different than you show. Are you using multiple coordinate systems in your graph, or do you have multiple sets of data, with different ranges? Maybe one of data value in your dataset is completely outside of the range of all of your other values. Or maybe when you create the x-axis and x-axis labels, you have one set of coordinate system values (and the axis auto-scale to those values), but you later re-scale the coordinate system min and max values to new data, but the x-axis still uses the original values.

We do not see any email from you. If you already sent it, what email address did you use? Send it again, use support@quinn-curtis.com

Quinn-Curtis Forums © 2000-07 Quinn-Curtis, Inc. Go To Top Of Page
Powered By: Snitz Forums 2000 Version 3.4.07